This site requires JavaScript, please enable it in your browser!
Greenfoot back

Report as inappropriate.

Spilli
Spilli presents ...

2010/6/11

Matrix Effect

Since Java doesn't support matrix like characters I've had to use binary characters '0, 1' instead
this is quite simple to edit and I hope the source code is understanable for everyone.

3859 views / 15 in the last 7 days

11 votes | 0 in the last 7 days

Tags: demo with-source binary matrix, painting, effects,

This scenario is a member of: sfx (special effects)


open in greenfoot
Your browser does not support the canvas tag.
MathManiacMathManiac

2011/4/10

Since It's 1's and 0's, how about you transform the text into bytes? they are binary, and when converting into Strings, you basically don't have to! As you add it to the arguments, the JVM(Java Virtual Machine, the thing that runs the program) automatically converts it into a String!
SpilliSpilli

2011/4/11

Maybe but raw binary is only 0's and 1's, nothing else. If you're wanting to use ASCII characters it's easily changeable, thanks for the response though.
DenzienDenzien

2012/6/29

There needs to be more numbers coming down at once for it to be like the Matrix, but good work :)
YomanYoman

2012/7/5

I think this is really neat stuff. i am making a library app, like where you log in, and see which book you've loged out, see the catalog etc. I am a total beginner in java, so i was wondering how you made it so that the program connected with the greenfoot server and into the user's account. because in my thing, everyone who uses it has an account
YomanYoman

2012/7/5

oh, by the way, could you reply to the previous comment on my library page? Thanx!
trimiltrimil

2013/9/19

In your code: {code} /** * Used to get the colour of the text depending on * the distance from the start to the end of the journey * @return Returns the colour of the falling code */ public Color getColour() { int i = ((getY() / 10) * 7); int alpha = i > 255 ? 255 : i; return new Color(colour.getRed(), colour.getGreen(), colour.getBlue(), IS_LEADER ? 200 : alpha); } {/code} you should use a different name for your variable "i" because variables named i are, in java, used for loop counters and should not be used for anything else.

Want to leave a comment? You must first log in.

Who likes this?

nachocab edparrish Game/maniac Poli JetLennit solokeh SPower Yoman Denzien Wyatt915 MathManiac