This site requires JavaScript, please enable it in your browser!
Greenfoot back

Comments for New Super Mario Bros. Greenfoot

Return to New Super Mario Bros. Greenfoot

A new version of this scenario was uploaded on 2018-11-26 22:08:54 UTC probably works now
A new version of this scenario was uploaded on 2018-11-26 22:11:56 UTC probably works now
nolttr21nolttr21

2018/11/26

for me it just shows a black screen with white text saying initializing... I guess just click the open in Greenfoot button and play it there.
A new version of this scenario was uploaded on 2019-01-07 22:47:59 UTC Temporaly removed sound
tgitaritgitari

2019/10/3

Didn't work kept getting a sound error
A new version of this scenario was uploaded on 2019-10-04 12:49:55 UTC Can choose from three characters now
nolttr21nolttr21

2019/10/4

I am very sorry about that. It works just fine if you download the scenario and play on the greenfoot application. I think it has something to do with the way that scenarios are translated to HTML5
danpostdanpost

2019/10/6

To hopefully run here, remove Greenfoot.start();.
A new version of this scenario was uploaded on 2019-10-07 17:55:35 UTC removed Greenfoot.start()
nolttr21nolttr21

2019/10/7

I can read something about a runtime exception, but the end gets cut off and I can't read what it says. Can anyone else see what is says?
danpostdanpost

2019/10/7

I think the cut-off word may be "Environment". However, I am not sure where that might suggest to look in your code.
danpostdanpost

2019/10/7

I would suggest moving everything from the inner (main) folder out into the outer folder (New Super Mario Bros. Greenfoot). Also, remove the PowerPoint files from within the 'images' folder'.
A new version of this scenario was uploaded on 2019-10-08 11:03:00 UTC Removed some redundant files from the project folder
nolttr21nolttr21

2019/10/8

Did you also want me to remove images from that mario, luigi and toad folders within the images folder?
danpostdanpost

2019/10/8

Yes. Move those images from the subfolders into the 'images' folder.
A new version of this scenario was uploaded on 2019-10-08 15:21:17 UTC Moved images out of folders
nolttr21nolttr21

2019/10/8

Hmm, still not working. I must be missing something...
danpostdanpost

2019/10/8

It's really a process of elimination. I am not sure what to try next. Maybe remove static content from the initial world class.
A new version of this scenario was uploaded on 2019-10-08 17:51:25 UTC removed static content from StartMenu class
nolttr21nolttr21

2019/10/8

Ok, looks like it works now, thanks for your help Danpost! I still need to update the timings of some of the animations but I don't need any help with that.
AndyGunAndyGun

2019/10/21

This Is Cool!
JohnGomesJohnGomes

2019/11/27

Awesome!
nolttr21nolttr21

2019/12/2

Glad you both liked it!
oreokkatoreokkat

2019/12/3

cool beans
Nate2002Nate2002

2 days ago

The cream of the crop