This site requires JavaScript, please enable it in your browser!
Greenfoot back
srk0008 wrote ...


Strange Glitch

srk0008 srk0008


Our class has started working on the Greeps project. When we were setting the memory, which has to be between 0 and 255 or it throws an error, we thought we had everything taken care of. It compiled fine, and it seemed to run fine. Only thing was, on my computer, it was a bit glitchy. It would pause for a second, but then it would continue running. First I thought that was just my computer, because it's a laptop, so not the greatest or fastest of processors. When we submitted it and it ran on the TA's computer, within half a second, it ran into an error. It had tried to set the memory outside the bounds. We were confused beyond belief. I ran it on my computer, and no problems, so the TA tried it again, and again it hit an error. We fixed the error, still scratching our heads, and it ran fine. Then we did more modifications. Again, it ran a little glitchy, but otherwise fine on my machine, but as soon as we took it to another machine, it started throwing errors. And we didn't take just the modified class, we took the whole project. We fixed those errors on that machine, then continued to modify it. It compiled and ran fine on that machine, but again in the runtimes it had the whole pause then continue running thing all over again. We then tried it on my machine. All of the sudden, it started throwing errors. Help and input on why it is being so temperamental about throwing errors would be greatly appreciated.
nccb nccb


Could you zip up your code and send it to, so that we can take a look? And do the machines that you were trying to run the code on have different versions of Greenfoot?
You need to login to post a reply.